Step by step

  1. Start the Help Editor.
  2. Start a new help project using the Help Project Wizard.
    When it is finished you will have all HTML Help Project files and supporting files like style sheet and templates available in your project folder.
  3. Editing the help project - now it is time to add content pages to your project.
    On the Contents Tree dockable window , the top ...[help project], right-click New. This opens the dialog below.
     
    Enter a page title. Change or keep the automatically generated page name.
    In the select the type of page you want to add, in our case we select the 'Overview' template, as we are about to create our first page. (See Creating Topic files for alternative ways to creating new topic pages.)
    Now a new page is created with the Title in the <h1> automatically set and you can start typing text into the page. The new page is added to the content tree. Add some extra pages with hyperlink and quick parts. A complete set of editing tools are available from the Edit tab and the Insert tab on the ribbon. The latter includes the Capture tools, which let you capture both images and texts to use directly in the help project.
    Generate Document even lets you automatically create a complete descriptive page with screenshot, control sections, giving you a jumpstart on documenting the user interface.
  4. Review - before publishing you should check for problems, especially regarding broken links which are most annoying to the users.
    On the Help Editor's ribbon, select the Review tab. Press the Broken Links button, which opens the Broken Links report. You can open pages to fix using double-click.
  5. Publish
    On Backstage (=File tab,) press Publish .
    Press the 'Compile Help Project', 'Compile Web Based Help' or 'Documentation in Word' button, whichever you require.
    If your help is to be used as help for a software application, link the help content pages where appropriate in your application.
Introducing the Help Generator